Results 1 to 10 of 10

Thread: [ Bind Issue ]

  1. #1

    MTA Mapping Expert
    •PM For Map Requests•
    buckeyesdb's Avatar
    Join Date
    Dec 2012
    Posts
    414
    Rep Power
    8

    [ Bind Issue ]

    With the newer gate system, you have to do /gate [password] instead of /[password]. When I bind this I use /bind 3 gate [password]. Anytime I restart MTA:SA, it removes the bind, completely. I've tried using the console to set them then /disconnect'ing but it did the same. I went into the coreconfig.xml and manually created the bind but when I go onto the server, it does not work, then I reopen the .xml and the bind line is gone. And I did double check, it is upon connecting to MTA:RP it removes the bind, not necessarily when I close MTA:SA. I have had this problem before with other command and it was due to the account-system. It was setting 1, 2, and 3 to languages. Not sure if it matters, 3 also has a couple other binds on it such as /duty and /watch [password].


    This is the line I use in the .xml:

    <bind key="3" state="down" command="gate" arguments="PASSWORD"></bind>
    (No, PASSWORD is not actually my password, but for the ease of discussion, we will use it.)


    It is just weird because while I'm ingame, and I bind it, it works the rest of the time, until I close MTA:SA. Everytime I get on the server I have to rebind it and the password is somewhat long so I definitely want it bound.

    Anybody know the issue or have a solution?
    Last edited by buckeyesdb; August 7th, 2014 at 02:51 AM.
    As of 9/13/2014



    www.Game-State.com

  2. #2
    MTARP User masterchief's Avatar
    Join Date
    Aug 2013
    Location
    Blaine Minnesota
    Age
    21
    Posts
    536
    Rep Power
    8

    Re: [ Bind Issue ]

    Quote Originally Posted by buckeyesdb View Post
    With the newer gate system, you have to do /gate [password] instead of /[password]. When I bind this I use /bind 3 gate [password]. Anytime I restart MTA:SA, it removes the bind, completely. I've tried using the console to set them then /disconnect'ing but it did the same. I went into the coreconfig.xml and manually created the bind but when I go onto the server, it does not work, then I reopen the .xml and the bind line is gone. And I did double check, it is upon connecting to MTA:RP it removes the bind, not necessarily when I close MTA:SA. I have had this problem before with other command and it was due to the account-system. It was setting 1, 2, and 3 to languages. Not sure if it matters, 3 also has a couple other binds on it such as /duty and /watch [password].


    This is the line I use in the .xml:


    (No, PASSWORD is not actually my password, but for the ease of discussion, we will use it.)


    It is just weird because while I'm ingame, and I bind it, it works the rest of the time, until I close MTA:SA. Everytime I get on the server I have to rebind it and the password is somewhat long so I definitely want it bound.

    Anybody know the issue or have a solution?
    When i do it i disconnect from the server than quit mta maybe try that instead of just quiting immediatly? otherwise than idk

  3. #3

    MTA Mapping Expert
    •PM For Map Requests•
    buckeyesdb's Avatar
    Join Date
    Dec 2012
    Posts
    414
    Rep Power
    8

    Re: [ Bind Issue ]

    Quote Originally Posted by snarkygoldfish View Post
    When i do it i disconnect from the server than quit mta maybe try that instead of just quiting immediatly? otherwise than idk
    Tried that aswell
    As of 9/13/2014



    www.Game-State.com

  4. #4

    MTA Mapping Expert
    •PM For Map Requests•
    buckeyesdb's Avatar
    Join Date
    Dec 2012
    Posts
    414
    Rep Power
    8

    Re: [ Bind Issue ]

    #INeedBraunson
    As of 9/13/2014



    www.Game-State.com

  5. #5
    The real MVP Braunson's Avatar
    Join Date
    Nov 2012
    Location
    Canada
    Posts
    1,188
    Rep Power
    9

    Re: [ Bind Issue ]

    Hi. So to confirm are you running the latest and STABList build of MTA? Not downloading the nightlys are you?

    In the latest 1.4 update a bug was fixed that would delete custom binds when MTA was not shut down properly. Also have you tried running it as a administer? It's possible MTA is not properly reading/writing the binds because of insufficient permissions.
    I used to script hurr'


    Formerly bmazoka

  6. #6

    MTA Mapping Expert
    •PM For Map Requests•
    buckeyesdb's Avatar
    Join Date
    Dec 2012
    Posts
    414
    Rep Power
    8

    Re: [ Bind Issue ]

    Quote Originally Posted by Braunson View Post
    Hi. So to confirm are you running the latest and STABList build of MTA? Not downloading the nightlys are you?

    In the latest 1.4 update a bug was fixed that would delete custom binds when MTA was not shut down properly. Also have you tried running it as a administer? It's possible MTA is not properly reading/writing the binds because of insufficient permissions.
    No nightly's, nope. I ran it as admin like you said and it saved one of my /gate [password]'s but not the other. When I do it ingame, and check the .xml, it does this:



    That is on
    'U', not '3' but I just haven't attempted to re-assign it yet. It just seems weird it allows one of them to stay, but the second one does not.

    EDIT: I just bound Password2 to 3 while Password1 was on U. I disconnected and quit. The binds were in the .xml, I started to connect to the server and while it did that, I reloaded the .xml and it removed Password2, but kept Password1. Weeeiirrddd


    EDIT#2: SOO... I think I found the problem. I was able to keep one bind on'U' but couldn't put the other one on it aswell, so I put it on 'N'. Both stayed fine and dandy after restart and reconnect. All is good. I went into the Binds Interface and set them both to '3' and disconnected and restarted and reconnected. BOTH were removed. It seems it will not allow me to have two /gate's on the same key, and if there's two, it removes both. Know a fix for that other than just using separate keys?
    Last edited by buckeyesdb; August 9th, 2014 at 01:49 AM.
    As of 9/13/2014



    www.Game-State.com

  7. #7
    The real MVP Braunson's Avatar
    Join Date
    Nov 2012
    Location
    Canada
    Posts
    1,188
    Rep Power
    9

    Re: [ Bind Issue ]

    Its possible a script is removing your binds on "u" for other purposes.

    Does it happen on other servers? MTA:RP does not use u for scripts.
    I used to script hurr'


    Formerly bmazoka

  8. #8

    MTA Mapping Expert
    •PM For Map Requests•
    buckeyesdb's Avatar
    Join Date
    Dec 2012
    Posts
    414
    Rep Power
    8

    Re: [ Bind Issue ]

    Quote Originally Posted by Braunson View Post
    Its possible a script is removing your binds on "u" for other purposes.

    Does it happen on other servers? MTA:RP does not use u for scripts.
    It only removes it for 'U' if I bind them both to it. I have simply just /gate bound to '3' so when I add one of the password ones, it thinks theres two of them and removes the passworded one. Right now it is allowing me to have /gate password1 on 'U' , /gate password2 on 'N', and /gate on '3' without removing any of them, but if I go into the binds interface and reassign them to 3, next reconnect it will remove them.
    As of 9/13/2014



    www.Game-State.com

  9. #9
    The real MVP Braunson's Avatar
    Join Date
    Nov 2012
    Location
    Canada
    Posts
    1,188
    Rep Power
    9

    Re: [ Bind Issue ]

    This is a MTA bug, you should report it on their bug tracker
    I used to script hurr'


    Formerly bmazoka

  10. #10

    MTA Mapping Expert
    •PM For Map Requests•
    buckeyesdb's Avatar
    Join Date
    Dec 2012
    Posts
    414
    Rep Power
    8

    Re: [ Bind Issue ]

    Quote Originally Posted by Braunson View Post
    This is a MTA bug, you should report it on their bug tracker
    Yessur, thank ya
    As of 9/13/2014



    www.Game-State.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •